Автор Тема: При подключённой карте примус не определятся по USB  (Прочитано 12009 раз)

0 Пользователей и 1 Гость просматривают эту тему.

syaros

  • .
  • *
  • Сообщений: 106
Всем привет.

Примус собран на восьмой меге. Всё работает очень хорошо.
Есть только одна проблемка: при подключённой карте примус не определятся по USB, то есть нельзя залить настройки.
При подключении USB есть обычная мелодия, экран пустой.

Без карты всё ОК.
Пробовал отключать от компьютера все USB устройства, всё равно проблема существует.
Что можно предпринять?

Спасибо.

Медведь

  • .
  • *
  • Сообщений: 1228
Цитата: "slav0n"

Для нормальной работы USB Редактора качаем и устанавливаем -  
libusb-win32-filter-bin-0.1.12.1.rar

Пользователям Vista и Windows 7 - выставить для файла libusb-win32-filter-bin-0.1.12.1.exe режим совместимости с Windows XP SP2
Цитата: "Mugenx2"
Для Win х64 Это не подходит.

Для кочерги х64 (Win7 x64) есть небольшие проблемы и нужен немного другой драйвер http://sourceforge.net/projects/libusb- ... p/download с ним нормально работает, а то я был несколько в замешательстве когда форточки сообщили что примус не отвечает и кабель не подключен :sh_ok:



Драйвера ЛИБ ставили?
Какая ОС?
СОВА! Открывай! Медведь пришёл...

syaros

  • .
  • *
  • Сообщений: 106
У меня уже установлен libusb-win32-filter-bin-0.1.12.1.rar

Вот что он выдаёт когда примус определяется:

DLL version:   0.1.12.1
Driver version:   0.1.12.1

bus/device  idVendor/idProduct
bus-0/\.libusb0-0003--0x16c0-0x05df     16C0/05DF
- Manufacturer : slav0n
- Product      : Primuss3
  wTotalLength:         34
  bNumInterfaces:       1
  bConfigurationValue:  1
  iConfiguration:       0
  bmAttributes:         40h
  MaxPower:             5
    bInterfaceNumber:   0
    bAlternateSetting:  0
    bNumEndpoints:      1
    bInterfaceClass:    3
    bInterfaceSubClass: 0
    bInterfaceProtocol: 0
    iInterface:         0
      bEndpointAddress: 81h
      bmAttributes:     03h
      wMaxPacketSize:   8
      bInterval:        100
      bRefresh:         0
      bSynchAddress:    0

ОС: Windows XP SP3 32bit

Должно быть что то на экране примуса вовремя подключения по USB?

Speys

  • Глобальный модератор
  • .
  • *****
  • Сообщений: 932
(Нет темы)
« Ответ #3 : 12 Август 2011, 09:16:52 »
Цитата: "syaros"
Должно быть что то на экране примуса вовремя подключения по USB?
Нет, ничего,кроме звука сирены.

Медведь

  • .
  • *
  • Сообщений: 1228
Это для спектрума и при прошивке
А у него на 8 меге
Там обязательно примус должен быть вкючён и, если мне память не изменяет, карта так-же должна быть подключена, иначе комп прибор видеть не будет
На экране прибора подкючение к компьютеру ни как не сигнализируется
Как отображалось главное меню - так и будет отображаться - ни каких изменений
СОВА! Открывай! Медведь пришёл...

syaros

  • .
  • *
  • Сообщений: 106
Давайте подытожим все факты:
Примус на восьмой меге. Работает хорошо.
При попытке залить настройки(через USB), если карта подключена - есть только звуковой сигнал. На экране нет ничего. Примус не реагирует на нажатие кнопок.
Если не подключена - есть звуковой сигнал, на экране пусто, примус реагирует на нажатие кнопки *.

Есть ещё одна странность:
Если подключаю амперметр на входе(по питанию 12В) - то примус не входит в режим сканирования спутника. То есть на экране такая же индикация как при не подключенном LNB:

slav0n

  • Администратор
  • .
  • *****
  • Сообщений: 4578
Цитата: "syaros"
Есть ещё одна странность
действительно, странно...
Может быть начинает "шуметь" преобразователь 12 - 5 В.
Керамикой его обвешать, дроссель проверить.
while(1||!1);
зберігай спокій

syaros

  • .
  • *
  • Сообщений: 106
Из керамики есть только 100nF. Где их ставить, на входе или на выходе? [Сейчас стоят и на входе и на выходе, как нарисовано на схеме]
Есть в наличии ещё 100uF электролит. Такой стоит на входе по даташиту ЛМ. Стоит поставить?

Замерил напряжение на полевом транзисторе. Напряжение питания(от компьютерного БП) 11.53В.
Вот результаты:
Карта не подключена --- Source: 11.48 --- Drain: 11.42 --- delta: 0.06
Карта подключена     --- Source: 11.37 --- Drain: 11.04 --- delta: 0.33
Карта подкл. + ЛНБ   --- Source: 11.31 --- Drain: 10.73 --- delta: 0.58

Получается что есть сильно большое падение напряжения на транзисторе...
Что делать?

Спасибо.

slav0n

  • Администратор
  • .
  • *****
  • Сообщений: 4578
Цитата: "syaros"
Получается что есть сильно большое падение напряжения на транзисторе...
Что делать?
Такого быть не должно.
Менять.
while(1||!1);
зберігай спокій

syaros

  • .
  • *
  • Сообщений: 106
Заменил транзистор - без изменений. Модель транзистора IRF9540.
Также заменил дроссель - без изменений.
Такое ощущение, что карта виновата...
Может попробовать подать на неё 5 вольт отдельно, а потом 12В отдельно и посмотреть когда будет проблема?

dansat

  • .
  • *
  • Сообщений: 875
Не греется ничего? Ток потребления какой от компового БП прибором?
Потребление узлов по отдельности можно еще проверить.

Медведь

  • .
  • *
  • Сообщений: 1228
У IRF9540 сопротивление перехода 0,2 Ома
А у указанного на схеме IRF5305 0,06 Ома
Разницы не видите?
СОВА! Открывай! Медведь пришёл...

syaros

  • .
  • *
  • Сообщений: 106
dansat,
Полевой транзистор греется, но с радиатором нормально.
Также греется LM, но с этим я тоже смирился.
Ток потребления с подключённой картой замерить не удаётся - я об этом тут писал...
Без карты - ток потребления ~75мА

Медведь,
Не хочу показаться не благодарным, но хочу возразить:
1. Вы писали, что себе ставили IRF9520, а там сопротивление перехода 0,6 Ома. У Вас были с этим проблемы?
2. Если однозначно стоит ставить IRF5305, то я их немедленно куплю.

Замерил также напряжение |VDS|
Без карты:         0.06В
С картой:           0.33В
С картой и ЛНБ: 0.58В

Спасибо.

Медведь

  • .
  • *
  • Сообщений: 1228
Цитата: "syaros"
1. Вы писали, что себе ставили IRF9520, а там сопротивление перехода 0,6 Ома. У Вас были с этим проблемы?
А если внимательно посмотреть, что именно я писал?
Цитата: "Медведь"
Полевой транзистор: IRF5305 - 1 шт. ( у меня стоит IRF9520 - по барски конечно, ну какой был под рукой)
Он на 100V расчитан, я его поставил только потому, что он у меня был и его на такие эксперименты - не жалко
У меня работало

Цитата: "syaros"
Полевой транзистор греется, но с радиатором нормально.
Не должен он греться от тока, потребляемого прибором
Если он греется - значит он греет сам себя, пожирая ток
Чем питаете прибор?
Если питалово слаботочное, напряжение будет просаживается - будет рости ток
Цитата: "syaros"
Ток потребления с подключённой картой замерить не удаётся - я об этом тут писал...
Так если Вы замахнулись на СПЕКТРУМА - не желаете потратиться на элементарный амперметр?
Просто сами посудите - как вам помочь, если Вам элементарные вещи (такие как померить ток) - "сделать не удаётся"? :ne_vi_del:
СОВА! Открывай! Медведь пришёл...

syaros

  • .
  • *
  • Сообщений: 106
Хочу ещё раз повторить, я не пытаюсь оспорить ваши ответы, или умничать, или что то другое в этом роде.
Я действительно хочу разобраться, с вашей помощью.

1. Примус питаю компьютерным БП. У него напряжение без нагрузки равно 11.53В. Максимальный заявленный ток БП - 40А.

2. У меня два мультиметра. Я ими обоими мерил ток до 750мА, когда собирал стабилизатор на LM. С обоими есть проблема замерить ток на примусе с подключённой картой и ЛНБ. То есть, когда я подключаю мультиметер, то примус не входит в режим сканирования, и ток потребления на мультиметре равен 300мА.

Без мультиметра, примус да входит в режим сканирования.